Can't install using webdeploy

Oct 5, 2016 at 6:55 AM
I have a windows 10 machine (Version 1607 Build 14393.222) where i installed webdeploy 3.5 (3.6 didn't show up in IIS).

When i try to deploy OrchardCollaboration i get the error "'enable32BitAppOnWin64' is not a valid attribute of the deployment object 'createApp'".

I have no idea where this attribute is defined so i can't remove it?

Does any one have a solution to this problem?
Oct 5, 2016 at 7:28 AM
Edited Oct 5, 2016 at 7:41 AM
I managed to get it to work by unselecting the 'Orchard.exe' file while installing, source: https://forums.iis.net/t/1174312.aspx
After the installation finished i just copied the exe again.

But i get http 500 when i try to access the site, any idea why?

The only output i managed to get is

Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) cs(Referer) sc-status sc-substatus sc-win32-status time-taken
2016-10-05 07:31:37 ::1 GET / - 80 - ::1 Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/51.0.2704.79+Safari/537.36+Edge/14.14393 - 500 19 33 0
Coordinator
Oct 10, 2016 at 9:00 AM
Can you please provide more information, which version are you trying to install? do you install it from web app gallery or not? did you try hosting it by simply copy the [Orchard Collaboration Web] to IIS (as it should simply work in this way)?
Oct 11, 2016 at 6:29 AM
Just extracting the compiled code from "Orchard Collaboration 2.5.1 Web" gave the same issue, i even gave all users write access to the folder.

I didn't try the web platform installer route as it was an older version 2.3 instead of 2.5.1.
Oct 18, 2016 at 1:26 PM
Any idea what could be wrong?
No event logs are created, the only thing i managed to pull out is the HTTP 500.19 error from IIS with the win32 status 33, but i have no idea what that means.
Coordinator
Oct 22, 2016 at 3:54 PM
Hi,

It could be related to IIS configurarion and the App Pool that host the site.

few things to check:

1) Pipeline mode of the App pool must be managed pipeline.
2) CLR version of it must be V4.0

IIS user must have read/write permission on the App_Data folder.

If those things wouldn't fix the issue, we can handle a session to check that together. You can also contact me directly at info at orchardcollaboration.

Regards,
Siyamand
Oct 25, 2016 at 6:34 AM
Hi again
application pool settings:
Name: OrchardCollaboration
.NET CLR version: 4.0.3#####
Managed pipeline mode: Integrated

And the IIS User has write and read access to the whole folder.
But there dosen´t seem to be a App_Data folder? if you download "OrchardCollaboration-2.5.1 Web.zip" and open it up then navigate into OrchardCollaboration this is what you find

Directories:
bin
Config
Core
Media
Modules
Themes
Files:
COPYING.txt
Global.asax
LICENSE.txt
packages.config
Refresh.html
Web.config
Coordinator
Oct 27, 2016 at 6:57 AM
Hi,

I manually copy-paste the content of OrchardCollaboration-2.5.1 Web.zip/Orchardcollaboration to a web folder in IIS on a Windows 10 (with latest update) machine, restart IIS and it worked.

DId you also try the same with Orchard 10.1?
Jan 5 at 8:16 AM
Finally found the reason but im a bit confused.

I had to go to Program and Features -> Turn windows feature on or off -> IIS -> WWW Services -> Application Development Features -> ASP.NET 4.6
After that it started working, the thing that confuses me is that i have run .net 4.X pages in IIS before and they worked and when i configured my app pool i could pick .net 4.0...

Any way i hope this helps someone else!