using Bootstrap

Jul 6, 2016 at 2:45 PM
Hello,

I am new to Orchard and Orchard Collaboration. I been trying to solved the following error I get, when I try to build from source and deploy to Azure's web apps.

Source Error:

Line 1: @using Bootstrap;
Line 2: @using Orchard;
Line 3: @functions {

Source File: d:\home\site\wwwroot\Themes\Bootstrap\Views\Layout.cshtml    Line: 1

It works fine on the local machine. what am I missing?

Thanks
Stan
Jul 6, 2016 at 2:54 PM
Hello,

I forgot to add:

Compiler Error Message: CS0246: The type or namespace name 'Bootstrap' could not be found (are you missing a using directive or an assembly reference?)
Coordinator
Jul 8, 2016 at 8:53 AM
Hi Stan,

The problem is, there are *.cs files in the Bootstrap theme that we used and the "automated publish" of the VS doesn't copy those cs files. We have plans to clean the theme from cs files in the next releases.

By copy the Bootstrap theme to the published site, it will be solved.

If you don't have any changes, you can use the Web package of Orchard collaboration here:
https://orchardcollaboration.codeplex.com/releases/view/624842


Regards,
Siyamand